Author Topic: Re: Русификатор не работает!  (Read 471 times)

0 Members and 1 Guest are viewing this topic.

operator

  • Jr. Member
  • **
  • Posts: 1
Re: Русификатор не работает!
« on: May 26, 2017, 07:08:48 PM »
Здрасте!
У меня такая же проблема, но я использовал автоустановку через cPanel
залил папку "ru"  в директ: /public_html/mibew/locales
в файле: /public_html/mibew/configs/config.yml прописал вместо en на ru
но зайдя в  настройки /mibew/operator/settings жму на "en" в Language of the messages left by visitors
но к сожалению вкладочка "ru" не появляется не могу выбрать русский язык.
Что делать? Как русифицировать mibew после автоустановки через cPanel?
« Last Edit: May 26, 2017, 07:15:31 PM by operator »


faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 748
    • Mibew Messenger
Re: Русификатор не работает!
« Reply #1 on: May 26, 2017, 09:50:58 PM »
0. Не коверкайте, пожалуйста, русский язык.

1. Не вводите людей в заблуждение. У Вас не "та же проблема". В оригинальном топике, куда Вы написали, речь шла о старом Mibew Messenger ветки 1.6. У Вас - Mibew Messenger 2.x (Вы не предоставили никаких деталей, но об этом говорит название файла конфигурации). Системы локализации у разных версий Mibew Messenger абсолютно разные.

2. Что Вы делаете в интерфейсе я так и не понял. И понимать не хочу. Вот, что Вам нужно сделать для локализации, по шагам:

а) переходите в Translations -> Locales , находите там Русский (ru) , делаете enable , если эта локаль ещё не активирована;

б) если необходимо, то импортируете локаль. Translations -> Translations import , выбираете импорт в локаль Русский (ru) , отмечаете флажок Override existing translations, выбираете po-файл из пакета локализации и загружаете.

Вот после этого уже можете играть со значениями локали по умолчанию.