Author Topic: What versin of node and Gulp do I need?  (Read 637 times)

0 Members and 1 Guest are viewing this topic.

Noahp

  • Jr. Member
  • **
  • Posts: 3
What versin of node and Gulp do I need?
« on: May 06, 2020, 11:27:30 PM »
I've tried to compile the external API from source which failed hard so I'm guessing the source for Mibew is also based on the old versions of Node and gulp. I just need to know what versions to install so I can work with the source code. I would really love to compile the External API so we can get webhook notifications when a guest starts a chat.


faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 907
    • Mibew Messenger
Re: What versin of node and Gulp do I need?
« Reply #1 on: May 07, 2020, 06:38:28 AM »
1. There is a package.json file, the required versions are described there. Personally I'm unaware about any troubles with versions incompatibility. If you have any additional information, you're free to disclose it.

2. I don't understand what are you trying to do, but there is already THREAD_CREATE event that can be used for new chat notifications. See Mibew:Slack plugin or Mibew:Telegram plugin for details.

Noahp

  • Jr. Member
  • **
  • Posts: 3
Re: What versin of node and Gulp do I need?
« Reply #2 on: May 07, 2020, 06:18:52 PM »
I am getting errors when building using
Code: [Select]
gulp default:

Code: [Select]
C:\Projects\Git repos\mibew\src>gulp default
fs.js:35
} = primordials;
    ^

ReferenceError: primordials is not defined
    at fs.js:35:5
    at req_ (C:\Projects\Git repos\mibew\src\node_modules\natives\index.js:143:24)
    at Object.req [as require] (C:\Projects\Git repos\mibew\src\node_modules\natives\index.js:55:10)
    at Object.<anonymous> (C:\Projects\Git repos\mibew\src\node_modules\graceful-fs\fs.js:1:37)
    at Module._compile (internal/modules/cjs/loader.js:1156:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1176:10)
    at Module.load (internal/modules/cjs/loader.js:1000:32)
    at Function.Module._load (internal/modules/cjs/loader.js:899:14)
    at Module.require (internal/modules/cjs/loader.js:1042:19)
    at require (internal/modules/cjs/helpers.js:77:18)

Noahp

  • Jr. Member
  • **
  • Posts: 3
Re: What versin of node and Gulp do I need?
« Reply #3 on: May 07, 2020, 06:21:30 PM »
Some googling leads me here:
https://timonweb.com/posts/how-to-fix-referenceerror-primordials-is-not-defined-error/

Which seems to elude to the issue being that I'd have to downgrade to an older version of node which brings me back to the reason for my question.
I tried the shrink wrap method in the post but that did not work for me.

faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 907
    • Mibew Messenger
Re: What versin of node and Gulp do I need?
« Reply #4 on: May 07, 2020, 07:15:55 PM »
You didn't specified any details about your system, versions of software in use, etc.

However, yes, looks like there could be an incompatibility issue with gulp 3.x and modern versions of node.js. Try using elder node.js. Something like actual stable LTS v10.20.1.
« Last Edit: May 07, 2020, 08:20:41 PM by faf »