General > Support

gulp failed with error in plugin "gulp-xgettext"

(1/2) > >>


I'm trying to customize Mibew Messenger 3.5.1 and keep getting following message:

[16:58:46] Using gulpfile ~\Desktop\mibew\src\gulpfile.js
[16:58:46] Starting 'default'...
[16:58:46] Starting 'clean'...
[16:58:46] Finished 'clean' after 11 ms
[16:58:46] Starting 'js'...
[16:58:46] Starting 'chat-styles'...
[16:58:46] Starting 'page-styles'...
[16:58:46] Starting 'generate-tmp-po'...
[16:58:46] Starting 'chat-styles-handlebars'...
[16:58:46] Starting 'generate-pot'...
[16:58:47] 'generate-pot' errored after 239 ms
[16:58:47] Error in plugin "gulp-xgettext"
    Command failed: xgettext --force-po -o - --language="JavaScript" --keyword="trans" -
'xgettext' is not recognized as an internal or external command,
operable program or batch file.

    killed: false
    code: 1
    signal: null
    cmd: xgettext --force-po -o - --language="JavaScript" --keyword="trans" -
    domainEmitter: [object Object]
    domain: [object Object]
    domainThrown: false

[16:58:47] 'generate-tmp-po' errored after 255 ms
[16:58:47] 'default' errored after 273 ms

I tried node-v10.20.1 & node-v11.15.0 & node-v16.13.0 but none worked out. I also tried "npm install xgettext-js" command and double checked that "\src\node_modules\xgettext-js\xgettext.js" exist, and then gulp again.

Could you please help?
Thank you.

xgettext is a part of GNU gettext tools. The exact way to install it depends on the OS being used. Most probably you're using Windows. As it's written on the official site, there are pre-compliled binaries for Windows.

It went through a couple of times but got stuck again. This time the error message is as follows:

[22:11:39] Using gulpfile ~\Desktop\mibew\src\gulpfile.js
[22:11:39] Starting 'default'...
[22:11:39] Starting 'clean'...
[22:11:39] Finished 'clean' after 33 ms
[22:11:39] Starting 'js'...
[22:11:39] Starting 'chat-styles'...
[22:11:39] Starting 'page-styles'...
[22:11:39] Starting 'generate-tmp-po'...
[22:11:39] Starting 'chat-styles-handlebars'...
[22:11:39] Starting 'generate-pot'...
[22:11:41] Finished 'page-styles' after 2.16 s
[22:11:43] Finished 'chat-styles-handlebars' after 3.71 s
[22:11:43] Starting 'chat-styles-js'...
[22:11:43] Finished 'chat-styles-js' after 65 ms
[22:11:43] Finished 'chat-styles' after 3.82 s
[22:11:44] Finished 'js' after 5.34 s
[22:11:49] Finished 'generate-pot' after 9.92 s
[22:11:49] Starting '<anonymous>'...
[22:11:49] Finished '<anonymous>' after 367 ms
[22:11:49] Finished 'generate-tmp-po' after 10 s
[22:11:49] Starting 'pack-sources'...
[22:11:49] Starting 'composer-install'...
[22:11:49] Starting 'get-composer'...
[22:11:55] Finished 'get-composer' after 5.72 s
[22:11:55] Starting '<anonymous>'...
[22:12:10] Finished '<anonymous>' after 15 s
[22:12:10] Finished 'composer-install' after 21 s
[22:12:10] Starting 'bower-install'...
[22:12:18] 'bower-install' errored after 7.5 s
[22:12:18] Error: File not found with singular glob: C:/Users/Administrator/Desk
top/mibew/src/mibew/js/vendor/backbone/backbone.js (if this was purposeful, use
`allowEmpty` option)
    at Glob.<anonymous> (C:\Users\Administrator\Desktop\mibew\src\node_modules\g
    at Object.onceWrapper (events.js:422:26)
    at Glob.emit (events.js:315:20)
    at Glob.EventEmitter.emit (domain.js:485:12)
    at Glob._finish (C:\Users\Administrator\Desktop\mibew\src\node_modules\glob-
    at done (C:\Users\Administrator\Desktop\mibew\src\node_modules\glob-stream\n
    at Glob._processSimple2 (C:\Users\Administrator\Desktop\mibew\src\node_modul
    at C:\Users\Administrator\Desktop\mibew\src\node_modules\glob-stream\node_mo
    at Glob._stat2 (C:\Users\Administrator\Desktop\mibew\src\node_modules\glob-s
    at lstatcb_ (C:\Users\Administrator\Desktop\mibew\src\node_modules\glob-stre
[22:12:18] 'pack-sources' errored after 28 s
[22:12:18] 'default' errored after 39 s

This time it's bower-install error, sometimes it's composer-install error. I tried reinstall Nodejs & Git & GNU gettext, I also tried command "npm cache clean" & "npm install" & "npm audit fix" but couldn't proceed.

Any advice? Thank you.

Frankly the only reasonable advice personally I can give is to not use Windows as a building environment. I've just checked the building process using VM with the actual LTS version of Ubuntu onboard. All went nice. As well as on our domestic test system with a completely different GNU/Linux distro. Probably (and even highly likely) there are some best practices on how to properly configure Windows-based node.js environment, but I'm unaware of them.

Honestly speaking, the program is not convenient. Currently user can only edit CSS files without rebuilding system. Could you guys make some change to let user freely edit all files under "styles" directory? In that way, Mibew Messenger will become much more popular.
Thank you.


[0] Message Index

[#] Next page

Go to full version