Mibew Messenger Community

General => Support => Topic started by: mikew on March 22, 2021, 09:52:20 AM

Title: SSL redirect problem
Post by: mikew on March 22, 2021, 09:52:20 AM
We use a special proxy https://www.internetx.com/en/proceed/ (https://www.internetx.com/en/proceed/)
it redirects from http -> https
But it bringst follow error:
File not found: http://www.domain.de/mibew/styles/chats/default/iframe.css
File not found: http://www.domain.de/mibew/plugins/Mibew/Mibew/Plugin/AdvancedButton/js/refresh.js
I added the proxy IP at config.yml without success.
At config Settings -> Options i set all SSL to on.
Where can i change in the code 'http' to 'https' ?
Title: Re: SSL redirect problem
Post by: faf on March 22, 2021, 08:44:54 PM
Mibew Messenger use Symfony for routing (https://symfony.com/doc/current/routing.html).

If you proxying https-requests to http-backend, just set several environmental variables related to protocol (namely, HTTPS should be set to on and HTTP_SCHEME to https), and Symfony will do the magic.

Alternatively, one could alter the config/routing.yml this way (https://symfony.com/doc/2.6/cookbook/routing/scheme.html). But I wouldn't recommend that way: one will have to manually update routes during each system update.