Author Topic: SMTP Settings (Mibew 3.2.7)  (Read 464 times)

0 Members and 1 Guest are viewing this topic.

julianx2rl

  • Jr. Member
  • **
  • Posts: 1
SMTP Settings (Mibew 3.2.7)
« on: January 07, 2021, 09:59:17 PM »
OK, so... I know this question has been asked before and that there's some advice in the FAQ but... the old questions are from around a decade ago and I followed the FAQ's advice but nothing.

So I have a problem with the mailing system that's supposed to send an email when no moderators are connected, when I try to use it, a dotted spinning wheel appears and never stops.

I'm supposed to set mibew to use a SMTP server,  but I already tried including the following in config.yml:

mailer:
    transport: "smtp"
    host: "smtp.xxx.xx.xx"
    port: 587
    user: "xxx@xxx.xx.xx"
    pass: "xxx"
    encryption: false

I also tried editing the files vendor/swiftmailer/swiftmailer/lib/classes/Swift/SmtpTransport.php and /configs/default_configs.yml

So yeah, some advice would be much appreciated, and thank you for your attention.


P.D: I actually managed to make the Drupal SMTP settings work, so at least I know the host is working just fine... but still.
« Last Edit: January 07, 2021, 10:01:16 PM by julianx2rl »


faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 912
    • Mibew Messenger
Re: SMTP Settings (Mibew 3.2.7)
« Reply #1 on: January 08, 2021, 09:25:33 AM »
If you're sure that your mail server works fine, something is wrong with the configuration of Mibew Messenger and/or with the accessibility of your mail server from your web server. One should check the logs of both servers for any errors.

I also tried editing the files vendor/swiftmailer/swiftmailer/lib/classes/Swift/SmtpTransport.php

It's almost always a bad idea to mess with an included vendor software. Unless it's absolutely necessary and you're really know what you're doing.

/configs/default_configs.yml

It's useless. That file is just an example of configuration. Mibew Messenger doesn't use it.