Author Topic: Problem with plugins  (Read 38 times)

0 Members and 1 Guest are viewing this topic.

shiads

  • Jr. Member
  • **
  • Posts: 3
Problem with plugins
« on: July 20, 2021, 07:38:19 AM »
Hi I am new using Mibew web messenger
it is quite great
but while i was installing plugins from the official site, i unrare them and upload them to plugins
but when I enter /operator/plugin" it says No elements
Where is the problem
I have installed latest mibew 3.4.3


faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 912
    • Mibew Messenger
Re: Problem with plugins
« Reply #1 on: July 20, 2021, 09:29:05 AM »
There could be two most possible causes for the issue in question:

1. Invalid directories structure (see https://docs.mibew.org/plugins/installation.html );
2. Insufficient rights of the webserver user to access plugins.

You didn't provide any details about your system environment, so that's all what could be said for now.

shiads

  • Jr. Member
  • **
  • Posts: 3
Re: Problem with plugins
« Reply #2 on: July 21, 2021, 03:25:33 AM »
Thank you very much for your reply, I am new in this world so I will try to explain what I do in detail:
I downloaded this addon:
Mibew:AdvancedButton plugin
https://github.com/Mibew/advanced-button-plugin

Then I unpacked it and uploaded it to the site like this:
mysite.com/chat/plugins/fof/Mibow/Plugin/AdvancedButton/Plugin.php
mysite.com/chat/plugins/fof/Mibow/Plugin/AdvancedButton/js/refresh.js
mysite.com/chat/plugins/fof/Mibow/Plugin/AdvancedButton/LICENSE
mysite.com/chat/plugins/fof/Mibow/Plugin/AdvancedButton/README.md

I am using paid hosting on ifastnet

when I modify config and add this code:
 
Code: [Select]
  plugins:
        "Mibew:AdvancedButton": # Plugin's configurations are described below
            mode: display
            submode: block

the chat pages gives this error:

This page isn’t working
mysite.com is currently unable to handle this request.
HTTP ERROR 500

I tried also to install the latest version v0.1.0, the same problem happened.
« Last Edit: July 21, 2021, 03:39:06 AM by shiads »

faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 912
    • Mibew Messenger
Re: Problem with plugins
« Reply #3 on: July 21, 2021, 10:17:00 AM »
I downloaded this addon:
Mibew:AdvancedButton plugin
https://github.com/Mibew/advanced-button-plugin

Where did you get it? Have you used the download link on the official site? Repository at Github should be used by developers, not by end users.

Then I unpacked it and uploaded it to the site like this:
mysite.com/chat/plugins/fof/Mibow/Plugin/AdvancedButton/Plugin.php

You were supposed to read the docs:

Quote
The files of the plugin should be placed in <mibew base path>/plugins/<Vendor name>/Mibew/Plugin/<Plugin name>/ directory

Vendor name here stands for a name of a plugin's developer. For official plugins the vendor name is Mibew. Obviously. And it's Mibew, not Mibow.

In your case the plugin should be placed in mysite.com/chat/plugins/Mibew/Mibew/Plugin/AdvancedButton/ .

the chat pages gives this error:

This page isn’t working
mysite.com is currently unable to handle this request.
HTTP ERROR 500

HTTP status 500 is Internal Server Error. There should be messages in the error log of your web server.

Most probably you've made some mistakes in configuration, it should be a valid file in YAML format.

shiads

  • Jr. Member
  • **
  • Posts: 3
Re: Problem with plugins
« Reply #4 on: July 21, 2021, 07:15:05 PM »
Thanks for you a lot, the problem was because I am downloading from github and not from mibew