Author Topic: Install Plugin gives blank screen  (Read 163 times)

0 Members and 1 Guest are viewing this topic.

Tomlemmens

  • Jr. Member
  • **
  • Posts: 3
Install Plugin gives blank screen
« on: December 21, 2021, 04:45:23 PM »
Hello,
For me it is the 1st time I use Mibew version 3.5.4 on a cpanel latest version, installation was no problem at all but if I want to install a plugin, I put it in the plugin folder, I change the config.yml (first with Sublimetext, failed - blank screen, then with Atom, also failed, also blank screen) I keep getting a blank screen after changing the config file, no error message, nothing... After I have returned the original config file posted everything works perfectly (without my plugins of course:-() I can't find a solution directly in the forum, see screenshots. How can I solve this?
Greetz, Tom


faf

  • Mibew Staff Member
  • Native
  • *****
  • Posts: 942
    • Mibew Messenger
Re: Install Plugin gives blank screen
« Reply #1 on: December 21, 2021, 08:42:02 PM »
0. Blank screen means that there was internal server error and PHP interpreter crushed. See your server logs for details.

1. You've installed plugins in a wrong way. Bad directories structure. See docs for details. That's why you're unable to see any plugins, even those that doesn't need to be configured.

2. You've configured plugins in a wrong way. The plugins section is corrupted with invalid framing of ```yaml ... ``` (where did you even get that?!) and wrong indents. It's YAML, so spaces matters. And (most probably) that's why you're getting blank screen.